application.js找不到jquery.ui.effect-blind

2020/12/31 17:51 · jquery ·  · 0评论

我正在尝试使用gem jquery-rails,但是我的application.js文件无法找到必要的文件(“找不到文件'jquery.ui.effect-blind'”)

我的application.js:

//= require jquery
//= require jquery.ui.effect-blind
//= require jquery_ujs
//= require turbolinks
//= require_tree .

在我的gemfile中,我有:

gem 'jquery-rails', "2.3.0"
gem 'jquery-ui-rails'

我已经看过几次这个问题,大多数人报告说是通过使用2.3.0版本的'jquery-rails'来解决的。我已经指定了它,并使用gem list命令确认了它,但是application.js文件仍然找不到它。我已经尝试过jquery.ui和jquery.ui.all,但是它们给出了相同的错误。

我遇到了一个类似的问题,事实证明,在某个时候,他们开始使用jquery-ui而不是jquery.ui/而不是.包括单个部分。尝试使用:

//= require jquery-ui/effect-blind

编辑

在最新版本effects中,路径中还有其他内容

//= require jquery-ui/effects/effect-blind

我不得不将其更改为

//= require jquery-ui/effects/effect-blind

这似乎是最近的。

https://github.com/jquery-ui-rails/jquery-ui-rails

本文地址:http://jquery.askforanswer.com/application-jszhaobudaojquery-ui-effect-blind.html
文章标签: ,   ,   ,   ,  
版权声明:本文为原创文章,版权归 admin 所有,欢迎分享本文,转载请保留出处!

文件下载

老薛主机终身7折优惠码boke112

上一篇:
下一篇:

评论已关闭!